Service disruption
Incident Report for Airtame
Resolved
The incident has been resolved.
Posted Oct 17, 2022 - 14:26 UTC
Investigating
We are currently experiencing a service disruption in our email provider.

Our Cloud team is working to identify the root cause and implement a solution. Any expected email from Cloud will not be received until the issue is solved.
Posted Oct 17, 2022 - 12:05 UTC
This incident affected: Airtame Cloud.